首 页 » 软件使用 » 在sublime text中右击打开ruby的require文件

在sublime text中右击打开ruby的require文件

[ 2014-04-01 20:09 | 浏览次数: 1,311次 | 0条评论 ]

在ruby代码中有类似于include的require语句,意思是加载某个库.

那能不能像在C或C++代码中一样,右击include语句就可以打开对应的文件呢?


下面介绍我写的一个脚本用来打开require文件

下载地址:http://pan.baidu.com/s/1hqDoI00

脚本开源在: http://git.oschina.net/hgyxbll/open_require_file

使用方法:

1. 将将open_require_file.rb和open_require_file.py文件放在sublime text的Data\Packages\User\目录

2. 新建Context.sublime-menu文件,在其中写入以下内容

[
    { "command": "open_require_file", "caption": "Open Require File" },
]

这样就可以在右键中添加菜单open_require_file

3.在ruby脚本中点击require所在的语句,右击选择Open Require File即可打开require的文件

image

您可以任意转载本文,但转载时请勿删除作者信息。
作者:hgyxbll,原文链接:http://shashanzhao.com/archives/956.html
上一篇: | 下一篇:

沙发为空,还不快枪?[点此发言]

目前还没有任何评论.