标签类目:sublime text

做了个sublime Text的中文语言包

[ 2015-04-13 23:14 | 分类:软件使用 | 浏览次数: 4,594次 | 2条评论 ]

语言包下载(对应Sublime Text 3.0 Build 3083):

http://pan.baidu.com/s/1eQ6crcQ

语言包项目地址:

http://git.oschina.net/hgyxbll

让sublime text3在终端中运行

[ 2014-09-01 23:01 | 分类:程序开发 | 浏览次数: 7,613次 | 3条评论 ]

一般情况直接在Sublime Text3中运行即可, 但如果需要读取用户的输入, 比如C/C++调用函数getchar,gets,cin, ruby中调用$stdin.gets,这时候在Sublime Text中运行就没有效果了,表现的问题就是无法输入数据, 这时就需要让其在外部终端中运行.

解决sublime text输出decode error问题

[ 2014-04-09 20:54 | 分类:软件使用 | 浏览次数: 8,582次 | 3条评论 ]

sublime text有时运行会输出以下错误信息:

[Decode error - output not utf-8]或者[Decode error - output not gbk]

让sublime text支持设置运行参数

[ 2014-04-04 21:30 | 分类:软件使用 | 浏览次数: 6,160次 | 2条评论 ]

sublime text支持编译运行各种脚本,然而却不能支持设置或指定运行参数.

在sublime text中设置某种扩展名文件的默认语法

[ 2014-04-03 21:21 | 分类:软件使用 | 浏览次数: 21,067次 | 6条评论 ]

对于正常扩展名(后缀)的文件,sublime text都能识别.

对于其他不寻常的扩展名,sublime text不能识别.

在sublime text中右击打开ruby的require文件

[ 2014-04-01 20:09 | 分类:软件使用 | 浏览次数: 1,311次 | 0条评论 ]

在ruby代码中有类似于include的require语句,意思是加载某个库.

那能不能像在C或C++代码中一样,右击include语句就可以打开对应的文件呢?

加强Ruby在sublime text的输出中的双击定位

[ 2014-03-30 11:16 | 分类:软件使用 | 浏览次数: 1,133次 | 0条评论 ]

在sublime text中运行代码错误时会输出一些信息,比如哪个文件抛出了异常等等.

在这些输出信息中一般可以双击定位到某个文件的某句,然而有些语句却不可以.

写ruby的编辑器推荐

[ 2014-03-19 23:11 | 分类:软件使用 | 浏览次数: 1,420次 | 0条评论 ]

俗话说磨刀不误砍柴工,好的编辑器可以写的更舒服,更快.